Skip to main content
VulnerabilityPublished Updated

CVE-2026-33557: Apache Kafka · Improper Validation of Specified Index, Position, or Offset in Input

Affects Apache KafkaSource CVE Database V5

0
Compare

Not known to be exploited · CVSS 9.1 Critical.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 59% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Apache Software FoundationApache KafkaAffected
  • >=4.1.0 <=4.1.1
Fixed in–
Mavenorg.apache.kafka/kafkapkg:maven/org.apache.kafka/kafkaOther threatsAffected
  • =4.1.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users running Apache Kafka versions 4.1.0 or 4.1.1 should explicitly configure the broker property sasl.oauthbearer.jwt.validator.class to org.apache.kafka.common.security.oauthbearer.BrokerJwtValidator to enforce proper JWT validation. Upgrading to Apache Kafka version 4.1.2, 4.2.0, or later is recommended as these versions include the fix that correctly validates JWT tokens by default. Patch status is not explicitly stated in the vendor advisory, but the fix is included starting from version 4.1.2. No other mitigation is indicated by the vendor advisory.

Description

A possible security vulnerability has been identified in Apache Kafka. By default, the broker property `sasl.oauthbearer.jwt.validator.class` is set to `org.apache.kafka.common.security.oauthbearer.DefaultJwtValidator`. It accepts any JWT token without validating its signature, issuer, or audience. An attacker can generate a JWT token from any issuer with the `preferred_username` set to any user, and the broker will accept it. We advise the Kafka users using kafka v4.1.0 or v4.1.1 to set the config `sasl.oauthbearer.jwt.validator.class` to `org.apache.kafka.common.security.oauthbearer.BrokerJwtValidator` explicitly to avoid this vulnerability. Since Kafka v4.1.2 and v4.2.0 and later, the issue is fixed and will correctly validate the JWT token.

References

Community reviews

Loading reviews…