CVE-2026-118664: Apache superset · decode-uri-component provides a more robust alternative to decodeURIComponent
Affects apache-supersetSource GCVE Database
Not known to be exploited · CVSS 8.2 High : upgrade to 6.1.0-r8 soon.
Data as of 5 Nov 2026, 02:00 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 4.0 | 8.2 |
|---|
- Patch
- Available – fixed in 6.1.0-r8
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade apache-superset to 6.1.0-r8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
CleanStartapache-supersetpkg:apk/cleanstart/apache-supersetOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade apache-superset to version 6.1.0-r8 or later, where the vulnerability is fixed by replacing decodeURIComponent with decode-uri-component. Since a patch is available, applying this official fix is the recommended mitigation.
Description
A high-severity security vulnerability exists in the apache-superset package prior to version 6.1.0-r8. The issue relates to the use of the decodeURIComponent function, which is less robust than the recommended decode-uri-component alternative. This vulnerability has been addressed in version 6.1.0-r8.