Skip to main content
VulnerabilityPublished

CVE-2026-45822: Apache superset · decode-uri-component through 0

Affects apache-supersetSource GCVE Database

0
Compare
Authoritative record:CVE-2026-45822· Medium 6.6

Not known to be exploited · CVSS 6.6 Medium : upgrade to 6.1.0-r8 when convenient.

Data as of 5 Nov 2026, 02:00 UTC

CVSS 4.0 base score
6.6Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.1.0-r8
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:U/S:N/AU:Y/R:U/V:D/RE:M/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade apache-superset to 6.1.0-r8.

Affected software

ProductAffectedFixed in
CleanStartapache-supersetpkg:apk/cleanstart/apache-supersetOther threatsAffected
  • <6.1.0-r8
Fixed in
  • 6.1.0-r8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade apache-superset to version 6.1.0-r8 or later, where this vulnerability has been fixed. No other mitigation steps are indicated.

Description

CVE-2026-45822 is a high-severity security vulnerability affecting the apache-superset package versions prior to 6.1.0-r8. The vulnerability is related to the decode-uri-component functionality. A fix is available in version 6.1.0-r8.

References

Community reviews

Loading reviews…