Skip to main content
VulnerabilityPublished Updated

CVE-2025-58457: Apache ZooKeeper · Insufficient Permission Check in AdminServer Snapshot/Restore Commands

Affects org.apache.zookeeper:zookeeperSource GCVE Database

0
Compare
Authoritative record:CVE-2025-58457· Medium 4.3

Not known to be exploited · CVSS 4.3 Medium : upgrade to 3.9.4 when convenient.

Data as of 4 Nov 2026, 18:17 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CISA-ADPCVSS 3.14.3
Patch
Available – fixed in 3.9.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade org.apache.zookeeper:zookeeper to 3.9.4.

Affected software

ProductAffectedFixed in
Mavenorg.apache.zookeeper:zookeeperAffected
  • >=3.9.0 <3.9.4
Fixed in
  • 3.9.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Apache ZooKeeper version 3.9.4. Users should upgrade to this version to fully remediate the vulnerability. Alternatively, mitigations include disabling the snapshot and restore commands via the 'admin.snapshot.enabled' and 'admin.restore.enabled' settings, disabling the AdminServer entirely with 'admin.enableServer', and ensuring the root ACL is not open, noting that ZooKeeper ACLs are not recursive.

Description

Apache ZooKeeper versions 3.9.0 through 3.9.3 have an insufficient permission check vulnerability in the AdminServer's snapshot and restore commands. Authenticated clients with lower privileges than intended can invoke these commands, potentially disclosing cluster state information. The issue is fixed in version 3.9.4.

References

Community reviews

Loading reviews…