Skip to main content
CVE-2025-58457VulnerabilityPublished Updated

CVE-2025-58457: Apache ZooKeeper · Improper Handling of Insufficient Permissions or Privileges

Affects Apache ZooKeeperSource CVE Database V5

0

Not known to be exploited · CVSS 4.3 Medium · fixed in 3.9.4 : update Apache ZooKeeper when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.9.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
Apache Software Foundation Apache ZooKeeperAffected
  • =3.9.0
Fixed in–

AI-suggested

To mitigate CVE-2025-58457, European organizations should prioritize upgrading Apache ZooKeeper to version 3.9.4 or later, where the permission check flaw is corrected. If immediate upgrading is not feasible, administrators should disable the snapshot and restore commands by setting 'admin.snapshot.enabled' and 'admin.restore.enabled' to false in the ZooKeeper configuration. Disabling the entire AdminServer interface via 'admin.enableServer' is another effective mitigation, especially if the AdminServer is not required for operational purposes. Additionally, review and tighten the root ACL permissions to ensure they do not grant open or overly permissive access, keeping in mind that ZooKeeper ACLs are not recursive and child nodes require explicit permissions. Network segmentation and access controls should restrict AdminServer access to trusted clients only. Monitoring and logging AdminServer command usage can help detect anomalous activities. Finally, incorporate this vulnerability into vulnerability management and patching cycles to ensure timely updates and compliance.

Description

Improper permission check in ZooKeeper AdminServer lets authorized clients to run snapshot and restore command with insufficient permissions. This issue affects Apache ZooKeeper: from 3.9.0 before 3.9.4. Users are recommended to upgrade to version 3.9.4, which fixes the issue. The issue can be mitigated by disabling both commands (via admin.snapshot.enabled and admin.restore.enabled), disabling the whole AdminServer interface (via admin.enableServer), or ensuring that the root ACL does not provide open permissions. (Note that ZooKeeper ACLs are not recursive, so this does not impact operations on child nodes besides notifications from recursive watches.)

References

Community reviews

Loading reviews…