Apache2: A cross-site scripting vulnerability exists
Affects apache2Source GCVE Database
Not known to be exploited · CVSS 6.1 Medium · fixed in 2.4.7-1ubuntu4.22+esm15 : update apache2 when convenient.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.7-1ubuntu4.22+esm15, 2.4.18-2ubuntu3.17+esm20, 2.4.29-1ubuntu4.27+esm11 +4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 25.10apache2pkg:deb/ubuntu/apache2?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 18.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
An official fix is available in Apache HTTP Server version 2.4.68. Users are strongly recommended to upgrade to this version or later to remediate the vulnerability. No additional mitigation steps are indicated beyond applying the official update.
Description
A cross-site scripting (XSS) vulnerability exists in the mod_proxy_ftp module of Apache HTTP Server versions 2.4.67 and earlier. This vulnerability occurs during the generation of HTML directory listings when listing FTP directory contents via forward or reverse proxy configurations. The issue is fixed in Apache HTTP Server version 2.4.68. Users running affected versions are advised to upgrade to this fixed version to mitigate the vulnerability.
References
- ubuntu.com/security/CVE-2026-29170 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-29170 (opens in a new tab)
- httpd.apache.org/security/vulnerabilities_24.html (opens in a new tab)
- httpd.apache.org/security/vulnerabilities_24.html (opens in a new tab)
- openwall.com/lists/oss-security/2026/06/08/5 (opens in a new tab)
- ubuntu.com/security/notices/USN-8516-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8589-1 (opens in a new tab)