Skip to main content
VulnerabilityPublished Updated

CVE-2026-33006: Apache2 · A timing attack against mod_auth_digest in Apache HTTP Server 2.4.66 allows a bypass of

Affects apache2Source GCVE Database

0
Authoritative record:CVE-2026-33006· Medium 4.8

Not known to be exploited · CVSS 4.8 Medium · fixed in 2.4.7-1ubuntu4.22+esm15 : update apache2 when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
4.8Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.7-1ubuntu4.22+esm15, 2.4.18-2ubuntu3.17+esm20, 2.4.29-1ubuntu4.27+esm11 +5
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=resoluteOther threatsAffected
  • <2.4.66-2ubuntu2.1
Fixed in
  • 2.4.66-2ubuntu2.1
Ubuntu 25.10apache2pkg:deb/ubuntu/apache2?arch=source&distro=questingOther threatsAffected
  • <2.4.64-1ubuntu3.4
Fixed in
  • 2.4.64-1ubuntu3.4
Ubuntu 24.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=nobleOther threatsAffected
  • <2.4.58-1ubuntu8.12
Fixed in
  • 2.4.58-1ubuntu8.12
Ubuntu 22.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=jammyOther threatsAffected
  • <2.4.52-1ubuntu4.20
Fixed in
  • 2.4.52-1ubuntu4.20
Ubuntu Pro 20.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=esm-infra/focalOther threatsAffected
  • <2.4.41-4ubuntu3.23+esm6
Fixed in
  • 2.4.41-4ubuntu3.23+esm6
Ubuntu Pro 18.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <2.4.29-1ubuntu4.27+esm11
Fixed in
  • 2.4.29-1ubuntu4.27+esm11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A timing attack against mod_auth_digest in Apache HTTP Server 2.4.66 allows a bypass of Digest authentication by a remote attacker. Users are recommended to upgrade to version 2.4.67, which fixes this issue.

References

Community reviews

Loading reviews…