Apache2:
Affects apache2Source GCVE Database
Not known to be exploited · public exploit available (Exploit-DB) · 81% EPSS · CVSS 6.1 Medium : upgrade to 2.4.18-2ubuntu3.12 as a priority.
Data as of 26 Oct 2026, 07:57 UTC
- EPSS
- 81.4% chance of exploitation in 30 days – higher than 99% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.18-2ubuntu3.12, 2.4.29-1ubuntu4.10
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
t = 0 is the CVE’s publication on cve.org
Disclosed: evidence found.
CVE published 14 Aug 2019
Detectable: evidence found.
nuclei template: Apache HTTP Server <=2.4.39 - HTML Injection/Partial Cross-Site Scripting
Weaponised: evidence found.
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
Timeline
CVE published
on cve.org
, t = 0
First Exploit-DB entry (opens in a new tab)
Apache Httpd mod_proxy - Error Page Cross-Site Scripting
, 61 days after disclosure
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade apache2 to 2.4.18-2ubuntu3.12; apache2 to 2.4.29-1ubuntu4.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu:Pro:14.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.7-1ubuntu4.22+esm15?arch=source&distro=esm-infra-legacy/trustyOther threats | Affected
| Fixed in– |
Ubuntu:16.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.18-2ubuntu3.12?arch=source&distro=xenialOther threats | Affected
| Fixed in
|
Ubuntu:18.04:LTSapache2pkg:deb/ubuntu/apache2@2.4.29-1ubuntu4.10?arch=source&distro=bionicOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Until an official fix is confirmed, administrators should review proxy configurations to avoid misconfigurations that cause the Proxy Error page to be displayed. Applying updates from the respective Linux distribution vendors (Ubuntu 14.04 LTS, 16.04 LTS, 18.04 LTS) when available is recommended.
Description
Apache HTTP Server versions 2.4.0 through 2.4.39 contain a limited cross-site scripting (XSS) vulnerability in the mod_proxy error page. This issue allows an attacker to manipulate the link on the error page to redirect users to a malicious page. Exploitation requires that the server has proxying enabled and is misconfigured such that the Proxy Error page is displayed.