Skip to main content
CVE-2026-29167VulnerabilityPublished Updated

Apache2: Use After Free vulnerability

Affects apache2Source GCVE Database

0
Compare
Authoritative record:CVE-2026-29167· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical · fixed in 2.4.7-1ubuntu4.22+esm15 : patch apache2 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.7-1ubuntu4.22+esm15, 2.4.18-2ubuntu3.17+esm20, 2.4.29-1ubuntu4.27+esm11 +4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=resoluteOther threatsAffected
  • <2.4.66-2ubuntu2.4
Fixed in
  • 2.4.66-2ubuntu2.4
Ubuntu 25.10apache2pkg:deb/ubuntu/apache2?arch=source&distro=questingOther threatsAffected
  • 2.4.63-1ubuntu1 – 2.4.64-1ubuntu3.5
8 affected builds
Fixed in–
Ubuntu 24.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=nobleOther threatsAffected
  • <2.4.58-1ubuntu8.15
Fixed in
  • 2.4.58-1ubuntu8.15
Ubuntu 22.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=jammyOther threatsAffected
  • <2.4.52-1ubuntu4.23
Fixed in
  • 2.4.52-1ubuntu4.23
Ubuntu Pro 20.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=esm-infra/focalOther threatsAffected
  • <2.4.41-4ubuntu3.23+esm6
Fixed in
  • 2.4.41-4ubuntu3.23+esm6
Ubuntu Pro 18.04 LTSapache2pkg:deb/ubuntu/apache2?arch=source&distro=esm-infra/bionicOther threatsAffected
  • <2.4.29-1ubuntu4.27+esm11
Fixed in
  • 2.4.29-1ubuntu4.27+esm11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Use After Free vulnerability in Apache HTTP Server with mod_ldap in per-directory configuration This issue affects Apache HTTP Server: from 2.4.0 through 2.4.67. Users are recommended to upgrade to version 2.4.68, which fixes the issue.

References

Community reviews

Loading reviews…