CVE-2026-29167: Apache HTTP Server · Use After Free
Affects Apache HTTP ServerSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical · fixed in 2.4.68 : patch Apache HTTP Server as a priority.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4.68
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 8 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Apache Software FoundationApache HTTP Server | Affected
| Fixed in– |
AI-suggested
Users should upgrade Apache HTTP Server to version 2.4.68 or later, which contains the official fix for this vulnerability. Patch status is confirmed by the vendor's advisory indicating the fix is included in 2.4.68.
Description
A critical Use After Free vulnerability (CWE-416) exists in the mod_ldap module of Apache HTTP Server affecting per-directory configuration. This vulnerability impacts Apache HTTP Server versions from 2.4.0 through 2.4.67. It allows for potential complete compromise of confidentiality, integrity, and availability. Users are advised to upgrade to version 2.4.68, which addresses this vulnerability.