CVE-2025-64173: Apollo Router Affected by an Access Control Bypass on Polymorphic Types
Affects apollo-routerSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 1.61.12 soon.
Data as of 4 Nov 2026, 18:37 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 1.61.12, 2.8.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade apollo-router to 1.61.12; apollo-router to 2.8.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| crates.ioapollo-router | Affected
| Fixed in
|
| crates.ioapollo-router | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Apollo Router versions 1.61.12 and later, and 2.8.1 and later. Users should update to these versions to remediate the vulnerability. If immediate update is not possible, ensure that access control directives (@authenticated, @requiresScopes, @policy) are applied consistently to both interface types/fields and their implementing object types/fields to avoid inconsistent enforcement. Customers not using these access control features or not applying inconsistent directives on polymorphic types are not affected and do not need to take action.
Description
Apollo Router has a vulnerability in its access control enforcement for polymorphic GraphQL types. The router enforces access control directives on interface types/fields but ignores directives on their implementing object types/fields if all implementations share the same requirements. This inconsistency can allow unauthenticated queries to bypass access controls by querying via interface types/fields lacking the proper directives. The issue affects Apollo Router versions before 1.61.12 and versions from 2.0.0-alpha.0 up to but not including 2.8.1. Fixed versions are 1.61.12 and 2.8.1 and later.
References
- github.com/apollographql/router/security/advisories/GHSA-x33c-7c2v-mrj9 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-64173 (opens in a new tab)
- github.com/apollographql/router/commit/75ca43ecb9d38423b63d09896702f9da425cc754 (opens in a new tab)
- github.com/apollographql/router (opens in a new tab)
- github.com/apollographql/router/releases/tag/v2.8.1 (opens in a new tab)
- apollographql.com/docs/graphos/routing/security/authorization (opens in a new tab)