CVE-2025-64347: Apollo Router Improperly Enforces Renamed Access Control Directives
Affects apollo-routerSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 1.61.12 soon.
Data as of 4 Nov 2026, 18:49 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 1.61.12, 2.8.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 7 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade apollo-router to 1.61.12; apollo-router to 2.8.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| crates.ioapollo-router | Affected
| Fixed in
|
| crates.ioapollo-router | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Update Apollo Router to version 1.61.12 or later, or 2.8.1 or later, where the vulnerability is fixed. If immediate update is not feasible, remove any renaming of the @authenticated, @requiresScopes, and @policy directives in the imports argument of the @link directive to prevent bypass. Customers not using renamed access control directives are not affected and do not need to take action.
Description
Apollo Router contained a vulnerability where renamed access control directives via @link imports were not properly enforced. This allowed unauthorized queries to bypass element-level access controls such as @authenticated, @requiresScopes, and @policy directives when renamed. The issue affects Apollo Router versions prior to 1.61.12 and versions from 2.0.0-alpha.0 up to but not including 2.8.1. The vulnerability has been fixed by updating the access control logic to respect renamed directives. Users should update to versions 1.61.12 or later, or 2.8.1 or later, or remove renames of these directives as a workaround.
References
- github.com/apollographql/router/security/advisories/GHSA-g8jh-vg5j-4h3f (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-64347 (opens in a new tab)
- github.com/apollographql/router/commit/78e4b20a2fc26cc5f141aa47992ed85375266a2b (opens in a new tab)
- github.com/apollographql/router (opens in a new tab)