CVE-2026-59180: Apprise is an open source library which allows you to send a notification to almost all of the most
Affects appriseSource GCVE Database
Not known to be exploited · CVSS 3.1 Low · fixed in 1.11.0 : update apprise when convenient.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.11.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSapprisepkg:deb/ubuntu/apprise?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSapprisepkg:deb/ubuntu/apprise?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
Apprise is an open source library which allows you to send a notification to almost all of the most popular notification services available. Prior to 1.11.0, Apprise HTTP-based notification plugins and HTTP attachment and config loaders in apprise/attachment/http.py and apprise/config/http.py follow HTTP redirects by default and resend user-configured auth headers and query parameters on the redirected request, allowing a compromised trusted destination or on-path attacker to receive secrets such as Authorization headers, bearer tokens, custom headers, and service keys. This issue is fixed in version 1.11.0.
References
- ubuntu.com/security/CVE-2026-59180 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-59180 (opens in a new tab)
- github.com/caronc/apprise/security/advisories/GHSA-856c-92hv-3vxx (opens in a new tab)
- github.com/caronc/apprise/pull/1610 (opens in a new tab)
- github.com/caronc/apprise/commit/68c0aef218055e4586cf4605fd6b56358f5f462d (opens in a new tab)
- github.com/caronc/apprise/releases/tag/v1.11.0 (opens in a new tab)