Skip to main content
CVE-2026-119576VulnerabilityPublished

ArcadeDB from 21.12.1 before 26.10.2 contains an authorization bypass vulnerability that allows users with only

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-119576· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 26.10.2 when convenient.

Data as of 30 Oct 2026, 16:51 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.05.3
CNA (VulnCheck)CVSS 3.14.3
Patch
Available – fixed in 26.10.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade arcadedb to 26.10.2.

Affected software

ProductAffectedFixed in
ArcadeDataarcadedbAffected
  • >=21.12.1 <26.10.2
Fixed in
  • 26.10.2
Mavenarcadedbpkg:maven/arcadedbOther threatsAffected
  • >=21.12.1 <26.10.2
Fixed in
  • 26.10.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in ArcadeDB version 26.10.2 and later. Users should upgrade to version 26.10.2 or newer to remediate this vulnerability. No other mitigation or temporary workaround is indicated.

Description

ArcadeDB versions from 21.12.1 up to but not including 26.10.2 have an authorization bypass vulnerability. This flaw allows users with only readRecord privileges to replace the shared GraphQL schema via the read-only query endpoint. By sending a crafted GraphQL type definition with a malicious @sql directive to the /api/v1/query/{database} endpoint, attackers can alter query results returned to other users, including administrators.

References

Community reviews

Loading reviews…