CVE-2026-103658: aspell security update
Affects aspellSource GCVE Database
Not known to be exploited · CVSS 5.9 Medium : upgrade to 0.60.8.1-2.oe2403sp4 when convenient.
Data as of 29 Oct 2026, 10:48 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.60.8.1-2.oe2403sp4
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 12 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade aspell to 0.60.8.1-2.oe2403sp4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP4aspellpkg:rpm/openEuler/aspell&distro=openEuler-24.03-LTS-SP4Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade GNU Aspell to version 0.60.8.1-2.oe2403sp4 or later, where these vulnerabilities are fixed. No other mitigation is required as the issues are addressed in the official release.
Description
GNU Aspell versions prior to 0.60.8.1-2.oe2403sp4 contain multiple heap-based buffer overflow and out-of-bounds read vulnerabilities in their dictionary loading and decompression components. These flaws allow an attacker to cause heap memory corruption, denial of service, memory disclosure, and potentially remote code execution by tricking a user into loading crafted dictionary or compressed files. The issues are fixed in version 0.60.8.1-2.oe2403sp4 and later.
References
- openeuler.org/zh/security/security-bulletins/detail/?id=openEuler-SA-2026-4631 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-103658 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-75818 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-75819 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-75820 (opens in a new tab)