CVE-2026-94422: xdg-dbus-proxy security update
Affects xdg-dbus-proxySource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 0.1.2-3.oe2403sp4 soon.
Data as of 29 Oct 2026, 10:46 UTC
Thin evidence
One scorer or none| CNA (redhat) | CVSS 3.1 | 8.8 |
|---|---|---|
| CNA (redhat) | CVSS 4.0 | 8.7 |
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.1.2-3.oe2403sp4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade xdg-dbus-proxy to 0.1.2-3.oe2403sp4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP4xdg-dbus-proxypkg:rpm/openEuler/xdg-dbus-proxy&distro=openEuler-24.03-LTS-SP4Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in xdg-dbus-proxy version 0.1.2-3.oe2403sp4 that fixes the message filtering bypass vulnerability. Users and administrators should upgrade to this fixed version to mitigate the risk. No other mitigation actions are indicated by the vendor advisory.
Description
xdg-dbus-proxy versions before 0.1.2-3.oe2403sp4 contain a vulnerability that allows bypassing message filtering on the D-Bus session bus by setting a reply serial number on non-reply messages. This flaw can be exploited by a malicious or compromised Flatpak app to execute arbitrary code outside its sandbox. The issue arises from incorrect message filtering implementation. A fix is available in version 0.1.2-3.oe2403sp4.