Skip to main content
VulnerabilityPublished

CVE-2026-103658: aspell security update

Affects aspellSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-103658· Medium 5.9

Not known to be exploited · CVSS 5.9 Medium : upgrade to 0.60.8.1-2.oe2403sp3 when convenient.

Data as of 29 Oct 2026, 10:48 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.60.8.1-2.oe2403sp3
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade aspell to 0.60.8.1-2.oe2403sp3.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP3aspellpkg:rpm/openEuler/aspell&distro=openEuler-24.03-LTS-SP3Other threatsAffected
  • <0.60.8.1-2.oe2403sp3
Fixed in
  • 0.60.8.1-2.oe2403sp3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version 0.60.8.1-2.oe2403sp3 is available that addresses these vulnerabilities. Users and administrators should upgrade to this version or later to mitigate these issues. No additional mitigation steps are indicated beyond applying the official patch.

Description

GNU Aspell versions prior to 0.60.8.1-2.oe2403sp3 contain multiple heap-based buffer overflow and out-of-bounds read vulnerabilities in their dictionary loading and decompression components. These flaws allow attackers to cause heap memory corruption, denial of service, and potentially code execution by tricking users into loading malicious dictionary or compressed files. The issues are fixed in version 0.60.8.1-2.oe2403sp3 and later.

References

Community reviews

Loading reviews…