Skip to main content
VulnerabilityPublished

CVE-2026-91953: freerdp security update

Affects freerdpSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 8.7 High : upgrade to 2.11.8-11.oe2403sp3 soon.

Data as of 29 Oct 2026, 10:37 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.11.8-11.oe2403sp3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade freerdp to 2.11.8-11.oe2403sp3.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP3freerdppkg:rpm/openEuler/freerdp&distro=openEuler-24.03-LTS-SP3Other threatsAffected
  • <2.11.8-11.oe2403sp3
Fixed in
  • 2.11.8-11.oe2403sp3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available in FreeRDP version 2.11.8-11.oe2403sp3 that addresses these vulnerabilities. Users and administrators should upgrade to this fixed version to mitigate the risks. No additional mitigations are specified by the vendor advisory.

Description

FreeRDP versions before 2.11.8-11.oe2403sp3 contain multiple vulnerabilities including heap buffer overflows, out-of-bounds reads, and uninitialized heap memory disclosures. These flaws arise from improper validation and indexing in negotiation request handling, USB redirection channel processing, and RPC gateway transport parsing. Exploitation can lead to client crashes, denial of service, information disclosure, and potentially remote code execution when combined with other vulnerabilities. A fix is available in version 2.11.8-11.oe2403sp3.

References

Community reviews

Loading reviews…