CVE-2026-91959: FreeRDP before 3.31.0 contains a buffer over-read vulnerability in the rts_read_result function
Affects freerdpSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium · fixed in 3.31.0+dfsg-0ubuntu0.24.04.1 : update freerdp when convenient.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.31.0+dfsg-0ubuntu0.24.04.1, 3.31.0+dfsg-0ubuntu0.26.04.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 15 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade the Ubuntu freerdp3 to 3.31.0+dfsg-0ubuntu0.24.04.1 (package) or 3.31.0+dfsg-0ubuntu0.26.04.1 (package).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 24.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available for this vulnerability. Users and administrators should apply the official updates provided for FreeRDP in their respective distributions to remediate the issue. Since this is not a cloud service, manual patching is required. No additional mitigation steps are indicated by the vendor advisory.
Description
FreeRDP before 3.31.0 contains a buffer over-read vulnerability in the rts_read_result function within the RPC gateway transport parser. Attackers can send a malicious BIND_ACK PDU with a truncated result entry to trigger an out-of-bounds read causing process abort.