CVE-2026-109242: freerdp security update
Affects freerdpSource GCVE Database
Not known to be exploited · CVSS 7.1 High : upgrade to 2:2.11.7-15.el8_10 soon.
Data as of 4 Nov 2026, 18:01 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 7.1 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.1 |
- Patch
- Available – fixed in 2:2.11.7-15.el8_10
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 12 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade the AlmaLinux to 2:2.11.7-15.el8_10.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| AlmaLinux 8freerdp | Affected
| Fixed in
|
| AlmaLinux 8freerdp-devel | Affected
| Fixed in
|
| AlmaLinux 8freerdp-libs | Affected
| Fixed in
|
| AlmaLinux 8libwinpr | Affected
| Fixed in
|
| AlmaLinux 8libwinpr-devel | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update fixing this vulnerability is available in FreeRDP version 2:2.11.7-15.el8_10. Users of affected Red Hat Enterprise Linux 8 systems should apply this update promptly. The vendor advisory confirms the availability of an official fix and provides instructions for applying the update. No additional mitigation steps are required beyond applying the patch.
Description
FreeRDP, an open-source implementation of the Remote Desktop Protocol, has a security vulnerability (CVE-2026-109242) that allows denial of service via uninitialized progressive tile handling. This issue is one of multiple denial of service vulnerabilities addressed in a recent security update. The vulnerability affects versions prior to 2:2.11.7-15.el8_10 and has been fixed in that release. The update is rated as Important by Red Hat and applies to multiple Red Hat Enterprise Linux 8 variants.
References
- access.redhat.com/errata/RHSA-2026:94510 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-109242 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-110837 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-111880 (opens in a new tab)
- bugzilla.redhat.com/2549790 (opens in a new tab)
- bugzilla.redhat.com/2552978 (opens in a new tab)
- bugzilla.redhat.com/2554625 (opens in a new tab)
- errata.almalinux.org/8/ALSA-2026-94510.html (opens in a new tab)