CVE-2026-91953: freerdp security update
Affects freerdpSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 8.7 High : upgrade to 2.11.8-11.oe2403sp1 soon.
Data as of 29 Oct 2026, 10:37 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.11.8-11.oe2403sp1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:XExploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade freerdp to 2.11.8-11.oe2403sp1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP1freerdppkg:rpm/openEuler/freerdp&distro=openEuler-24.03-LTS-SP1Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and the vulnerabilities are fixed in FreeRDP version 2.11.8-11.oe2403sp1. Users and administrators should upgrade to this version or later to remediate these security issues.
Description
FreeRDP versions before 2.11.8-11.oe2403sp1 contain multiple vulnerabilities including heap buffer overflows, out-of-bounds reads, and uninitialized memory disclosures. These flaws arise from improper validation and handling of certain protocol fields and messages, potentially allowing a malicious RDP server or man-in-the-middle to cause client crashes, denial of service, or enable remote code execution when combined with other vulnerabilities. The issues are fixed in version 2.11.8-11.oe2403sp1.
References
- openeuler.org/zh/security/security-bulletins/detail/?id=openEuler-SA-2026-4654 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-91953 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-91956 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-91959 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-91963 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-91964 (opens in a new tab)