FreeRDP before 3.32.0 contains a client-side heap out-of-bounds write vulnerability in general_LumaToYUV444 and
Affects freerdpSource GCVE Database
Not known to be exploited · CVSS 8.8 High · fixed in 3.32.0+dfsg-0ubuntu0.24.04.1 : patch freerdp soon.
Data as of 28 Oct 2026, 23:26 UTC
- Patch
- Available – fixed in 3.32.0+dfsg-0ubuntu0.24.04.1, 3.32.0+dfsg-0ubuntu0.26.04.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu freerdp3 to 3.32.0+dfsg-0ubuntu0.24.04.1 (package) or 3.32.0+dfsg-0ubuntu0.26.04.1 (package).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 24.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading FreeRDP to version 3.32.0 or later. The fixed versions are 3.32.0+dfsg-0ubuntu0.24.04.1 and 3.32.0+dfsg-0ubuntu0.26.04.1. Users should update to these versions to remediate the vulnerability.
Description
FreeRDP versions before 3.32.0 contain a client-side heap out-of-bounds write vulnerability in the functions general_LumaToYUV444 and general_ChromaV2ToYUV444. This flaw allows malicious RDP servers to send specially crafted RDPGFX AVC444 or AVC444v2 frames with odd-height region rectangles that cause memory corruption beyond the U/V planes. The vulnerability can lead to heap corruption and potentially remote code execution on the client side. The issue is fixed in FreeRDP version 3.32.0 and later.
References
- ubuntu.com/security/CVE-2026-111382 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-111382 (opens in a new tab)
- github.com/FreeRDP/FreeRDP/security/advisories/GHSA-f4pf-pgp4-f2r3 (opens in a new tab)
- vulncheck.com/advisories/freerdp-before-3.32.0-heap-out-of-bounds-write-in-avc444-yuv444-combine (opens in a new tab)