FreeRDP from 3.0.0 before 3.32.0 contains an uncontrolled resource consumption vulnerability in parse_nla_mode_pdu
Affects freerdpSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 3.32.0+dfsg-0ubuntu0.24.04.1 : patch freerdp soon.
Data as of 28 Oct 2026, 23:27 UTC
- Patch
- Available – fixed in 3.32.0+dfsg-0ubuntu0.24.04.1, 3.32.0+dfsg-0ubuntu0.26.04.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 16 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Ubuntu freerdp3 to 3.32.0+dfsg-0ubuntu0.24.04.1 (package) or 3.32.0+dfsg-0ubuntu0.26.04.1 (package).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 24.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading FreeRDP to version 3.32.0 or later. The affected versions listed are fixed in 3.32.0+dfsg-0ubuntu0.24.04.1 and 3.32.0+dfsg-0ubuntu0.26.04.1. No other mitigation is indicated by the vendor advisory.
Description
FreeRDP versions from 3.0.0 up to but not including 3.32.0 contain an uncontrolled resource consumption vulnerability in the parse_nla_mode_pdu function. This flaw allows unauthenticated attackers to exhaust server memory by sending TLS streams with bytes that do not start with the expected DER SEQUENCE tag, causing unbounded growth of the receive buffer before NLA authentication. The vulnerability has a high severity with a CVSS score of 7.5 and is fixed in version 3.32.0.
References
- ubuntu.com/security/CVE-2026-111378 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-111378 (opens in a new tab)
- github.com/FreeRDP/FreeRDP/security/advisories/GHSA-qpfh-m9w6-xf2x (opens in a new tab)
- vulncheck.com/advisories/freerdp-3.0.0-before-3.32.0-unauthenticated-memory-exhaustion-via-nla-frame-parser (opens in a new tab)