Skip to main content
CVE-2026-111379VulnerabilityPublished Updated

FreeRDP before 3.32.0 contains a heap buffer overflow vulnerability in persistent_cache_read_entry_v3 that allows

Affects freerdpSource GCVE Database

0
Authoritative record:CVE-2026-111379· High 7.0

Not known to be exploited · CVSS 7.0 High · fixed in 3.32.0+dfsg-0ubuntu0.24.04.1 : patch freerdp soon.

Data as of 28 Oct 2026, 23:27 UTC

CVSS 4.0 base score
7.0High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.32.0+dfsg-0ubuntu0.24.04.1, 3.32.0+dfsg-0ubuntu0.26.04.1
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 16 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CISA SSVC: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE ID reserved

    by VulnCheck

    , 3 hours before disclosure

  2. CVE published

    on cve.org

    , t = 0

  3. CISA SSVC assessment

    proof of concept public

    , 16 hours after disclosure

  4. In Threat Radar

    record ingested

    , 11 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA SSVC, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu freerdp3 to 3.32.0+dfsg-0ubuntu0.24.04.1 (package) or 3.32.0+dfsg-0ubuntu0.26.04.1 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=resoluteOther threatsAffected
  • <3.32.0+dfsg-0ubuntu0.26.04.1
Fixed in
  • 3.32.0+dfsg-0ubuntu0.26.04.1
Ubuntu 24.04 LTSfreerdp3pkg:deb/ubuntu/freerdp3?arch=source&distro=nobleOther threatsAffected
  • <3.32.0+dfsg-0ubuntu0.24.04.1
Fixed in
  • 3.32.0+dfsg-0ubuntu0.24.04.1
Ubuntu Pro 24.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 2.10.0+dfsg1-1.1ubuntu1 – 2.11.5+dfsg1-1ubuntu0.1~esm6
12 affected builds
Fixed in–
Ubuntu 22.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=jammyOther threatsAffected
  • 2.3.0+dfsg1-2build1 – 2.6.1+dfsg1-3ubuntu2.11
23 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/focalOther threatsAffected
  • 2.0.0~git20190204.1.2693389a+dfsg1-1 – 2.6.1+dfsg1-0ubuntu0.20.04.2+esm4
17 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSfreerdp2pkg:deb/ubuntu/freerdp2?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 2.0.0~git20170725.1.1648deb+dfsg1-1 – 2.2.0+dfsg1-0ubuntu0.18.04.4+esm6
19 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by upgrading to FreeRDP version 3.32.0 or later, specifically versions 3.32.0+dfsg-0ubuntu0.24.04.1 or 3.32.0+dfsg-0ubuntu0.26.04.1 as provided by Ubuntu. Users should update affected packages to these fixed versions to remediate the vulnerability.

Description

FreeRDP versions before 3.32.0 contain a heap buffer overflow vulnerability in the function persistent_cache_read_entry_v3. This flaw allows local attackers to corrupt memory by providing a crafted v3 persistent cache file with manipulated width and height values, causing a buffer overflow during data reading. The vulnerability can lead to potential code execution. A fix is available in FreeRDP version 3.32.0 and later.

References

Community reviews

Loading reviews…