CVE-2026-41425: Authlib · Cross-site request forging when using cache
Affects fastmcpSource GCVE Database
Not known to be exploited · CVSS 5.4 Medium : upgrade to 3.2.4_1 when convenient.
Data as of 3 Nov 2026, 22:58 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.2.4_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade fastmcp to 3.2.4_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewfastmcppkg:brew/fastmcpOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Authlib version 3.2.4_1. Users should upgrade to this version or later to remediate the vulnerability. The patch implements proper CSRF protection when using the cache parameter. Until upgraded, users should avoid using the cache parameter or implement additional CSRF protections as a temporary measure.
Description
Authlib's cache feature in OAuth integrations lacks CSRF protection, allowing cross-site request forgery attacks when the cache parameter is used. This affects multiple integration clients, including Starlette. The vulnerability arises because the state parameter fetched from the cache is not verified to belong to the client completing the auth flow. This can lead to an attacker’s account being linked to a victim’s session. Versions from 2.12.3 up to but not including 3.2.4_1 are affected. A fix is available in version 3.2.4_1.