CVE-2026-53538: python-multipart · Semicolon treated as querystring field separator enables parameter smuggling
Affects fastmcpSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 3.7 Low : upgrade to 3.4.0 when convenient.
Data as of 3 Nov 2026, 22:58 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 17% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.4.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade fastmcp to 3.4.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewfastmcppkg:brew/fastmcpOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade python-multipart to version 3.4.0 or later, which corrects the parsing behavior to treat only '&' as a field separator in compliance with the WHATWG URL standard. This update prevents parameter smuggling by ensuring consistent parsing between intermediaries and backend applications. No other mitigation is required as the issue is fully addressed by this official fix.
Description
The python-multipart library's QuerystringParser incorrectly treats the semicolon (';') as a field separator in application/x-www-form-urlencoded bodies, contrary to the WHATWG URL standard which only recognizes the ampersand ('&') as a separator. This discrepancy allows attackers to smuggle additional or overriding form fields past upstream components that follow the standard, potentially causing the backend to receive parameters unseen by the intermediary. The issue affects versions >=2.12.3 and <3.4.0 and is fixed in version 3.4.0.