Skip to main content
VulnerabilityPublished Updated

CVE-2026-44681: Fastmcp · Authlib OIDC Implicit/Hybrid Authorization Vulnerable to Open Redirect

Affects fastmcpSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 3.2.4_2 when convenient.

Data as of 3 Nov 2026, 22:58 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 16% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.4_2
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade fastmcp to 3.2.4_2.

Affected software

ProductAffectedFixed in
Homebrewfastmcppkg:brew/fastmcpOther threatsAffected
  • >=2.12.3 <3.2.4_2
Fixed in
  • 3.2.4_2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in Authlib version 3.2.4_2 that fixes this vulnerability. Deployments should upgrade to this fixed version or later to remediate the issue. Until patched, avoid enabling the OpenIDImplicitGrant and OpenIDHybridGrant flows if possible. The vendor advisory confirms the fix in 3.2.4_2. No other mitigations are specified or required.

Description

Authlib's OpenIDImplicitGrant and OpenIDHybridGrant authorization endpoints contain an unauthenticated open redirect vulnerability triggered by authorization requests missing the 'openid' scope. This causes the authorization server to issue an HTTP 302 redirect to an attacker-chosen URL without validating the redirect URI. The flaw affects servers supporting OIDC Implicit or Hybrid flows using Authlib versions >=2.12.3 and <3.2.4_2. No user authentication or valid client ID is required to exploit this. The vulnerability enables phishing attacks leveraging the trusted authorization server domain in the URL bar but does not leak tokens or codes directly.

References

Community reviews

Loading reviews…