CVE-2025-61920: Authlib is vulnerable to Denial of Service via Oversized JOSE Segments
Affects authlibSource GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 1.6.5 soon.
Data as of 29 Oct 2026, 23:57 UTC
- Patch
- Available – fixed in 1.6.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 10 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade authlib to 1.6.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIauthlib | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Authlib version 1.6.5 that enforces a 256 KB limit on decoded JWS/JWT header and signature segments. Deploy this patched release immediately to remediate the vulnerability. As additional defense in depth, reject JWS/JWT inputs exceeding a few kilobytes at the proxy or WAF layer and apply rate limiting on verification endpoints. Temporary workarounds include enforcing input size limits before passing tokens to Authlib and using application-level throttling to reduce amplification risk.
Description
Authlib versions up to 1.6.3 have a vulnerability in their JOSE implementation where unbounded JWS/JWT header and signature segments can be oversized. An attacker can submit tokens with base64url-encoded segments hundreds of megabytes in size, causing excessive CPU and memory usage during verification and resulting in denial of service. The issue is fixed in version 1.6.5 by enforcing a 256 KB size limit on these segments.
References
- github.com/authlib/authlib/security/advisories/GHSA-pq5p-34cr-23v9 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-61920 (opens in a new tab)
- github.com/authlib/authlib/commit/867e3f87b072347a1ae9cf6983cc8bbf88447e5e (opens in a new tab)
- github.com/authlib/authlib (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/10/msg00032.html (opens in a new tab)