CVE-2025-62706: Authlib · JWE zip=DEF decompression bomb enables DoS
Affects authlibSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium : upgrade to 1.6.5 when convenient.
Data as of 29 Oct 2026, 23:56 UTC
- Patch
- Available – fixed in 1.6.5
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 10 Oct 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade authlib to 1.6.5.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIauthlib | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Authlib version 1.6.5 that adds a maximum output size limit to DEFLATE decompression, preventing unbounded expansion. Until upgrading, applications should reject or strip JWE tokens with the 'zip=DEF' header to avoid triggering the vulnerability. Additional mitigations include enforcing strict maximum token sizes, failing fast on oversized inputs, and applying rate limiting to reduce the risk of denial of service. Forking the library to add bounded decompression is also a possible workaround.
Description
Authlib versions prior to 1.6.5 contain a vulnerability in the JWE 'zip=DEF' decompression handling that allows unbounded DEFLATE decompression. This can be exploited by an attacker who can supply decryptable tokens to cause excessive memory and CPU usage, resulting in denial of service. The issue arises because the decompression function does not enforce a maximum output size, allowing a small compressed ciphertext to expand into very large plaintext during decryption. No confidentiality or integrity impact is reported, but availability is severely affected. A fix is available in Authlib 1.6.5.
References
- github.com/authlib/authlib/security/advisories/GHSA-g7f3-828f-7h7m (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-62706 (opens in a new tab)
- github.com/authlib/authlib/commit/e0863d5129316b1790eee5f14cece32a03b8184d (opens in a new tab)
- github.com/authlib/authlib (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/10/msg00032.html (opens in a new tab)