Skip to main content
CVE-2026-114614VulnerabilityPublished

kimi-cli · Authlib: is_secure_transport() loopback exemption can be bypassed with a userinfo component, allowing cleartext-HTTP

Affects kimi-cliSource GCVE Database

0
Compare
Authoritative record:CVE-2026-114614· Low 2.6

Not known to be exploited · CVSS 2.6 Low : upgrade to 1.50.0 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
2.6Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.12.6
EPSS
0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.50.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade kimi-cli to 1.50.0.

Affected software

ProductAffectedFixed in
Homebrewkimi-clipkg:brew/kimi-cliOther threatsAffected
  • >=0.40 <1.50.0
Fixed in
  • 1.50.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Authlib version 1.50.0. Users should upgrade to this version or later to resolve the issue. Until then, users should be aware that the is_secure_transport() function may incorrectly accept certain HTTP URLs with userinfo components as secure. No other vendor advisories indicate alternative mitigations or that the issue is already mitigated.

Description

Authlib versions from 0.13 through 1.7.2 contain a vulnerability in the is_secure_transport() function, which incorrectly treats certain HTTP URLs with a userinfo component as secure loopback addresses. This allows an attacker to bypass the TLS enforcement by crafting URLs like http://localhost:80@evil.example/cb, which are accepted as secure despite being cleartext HTTP to an external host. The flaw affects OAuth 2.0 / OIDC endpoint and redirect URI validation, potentially allowing cleartext non-loopback URLs to be accepted where TLS is required. The severity is low, and a fix is available in version 1.50.0.

References

Community reviews

Loading reviews…