Skip to main content
VulnerabilityPublished

CVE-2026-110860: GitPython · Submodule.move() follows an attacker-committed intermediate symlink outside the worktree

Affects kimi-cliSource GCVE Database

0
Compare
Authoritative record:CVE-2026-110860· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 1.50.0 when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.9
CNA (VulnCheck)CVSS 3.16.1
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.50.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade kimi-cli to 1.50.0.

Affected software

ProductAffectedFixed in
Homebrewkimi-clipkg:brew/kimi-cliOther threatsAffected
  • >=1.11.0 <1.50.0
Fixed in
  • 1.50.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in GitPython version 1.50.0. Users and downstream applications should upgrade to version 1.50.0 or later to remediate this vulnerability. Until upgraded, applications should avoid calling Submodule.move() on paths that may include attacker-controlled symlinks. No other mitigations are documented or required.

Description

GitPython's Submodule.move() API does not properly handle symbolic links in intermediate path components, allowing an attacker-controlled symlink to redirect submodule moves outside the parent repository worktree. This can cause the submodule checkout to be moved to an attacker-chosen directory outside the intended repository, corrupting the repository's index and configuration. The vulnerability requires the attacker to control the cloned repository and commit a symlink, but no code execution or file overwrite was demonstrated.

References

Community reviews

Loading reviews…