Skip to main content
VulnerabilityPublished Updated

CVE-2025-62706: Authlib · JWE zip=DEF decompression bomb enables DoS

Affects fastmcpSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 2.12.4_1 when convenient.

Data as of 3 Nov 2026, 22:58 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.12.4_1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade fastmcp to 2.12.4_1.

Affected software

ProductAffectedFixed in
Homebrewfastmcppkg:brew/fastmcpOther threatsAffected
  • >=2.12.3 <2.12.4_1
Fixed in
  • 2.12.4_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Authlib version 2.12.4_1 that adds a maximum output size limit to DEFLATE decompression to prevent unbounded expansion. Until upgrading, applications should reject or strip JWE tokens with 'zip=DEF' compression at the application boundary. Additional mitigations include enforcing strict maximum token sizes, failing fast on oversized inputs, and applying rate limiting to reduce impact of repeated attacks.

Description

Authlib's JWE implementation with 'zip=DEF' (DEFLATE) decompression performs unbounded decompression without limits, allowing a small compressed ciphertext to expand into very large plaintext during decryption. This can cause excessive memory and CPU usage, leading to denial of service. The vulnerability affects services that decrypt JWE tokens with 'zip=DEF' where attackers can supply decryptable tokens. No confidentiality or integrity impact is reported, but availability is severely affected. A fix is available in version 2.12.4_1. Until patched, rejecting or stripping 'zip=DEF' tokens is recommended.

References

Community reviews

Loading reviews…