CVE-2026-114619: Authlib · OpenID implicit grant checks raw scope instead of allowed scope before issuing ID tokens
Affects fastmcpSource GCVE Database
Not known to be exploited · CVSS 4.6 Medium : upgrade to 4.1.1 when convenient.
Data as of 30 Oct 2026, 10:16 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 4.6 |
|---|
- Patch
- Available – fixed in 4.1.1
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade fastmcp to 4.1.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewfastmcppkg:brew/fastmcpOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Authlib version 4.1.1. Users should upgrade to this version or later to resolve the issue. No other mitigation is required as the vulnerability is addressed by correcting the scope validation logic in the OpenID implicit grant flow.
Description
Authlib's OpenID Connect implicit grant implementation improperly checks the raw requested scope instead of the filtered allowed scope before issuing ID tokens. This allows a registered OAuth client, which is not permitted the 'openid' scope but allowed other scopes like 'profile', to receive a signed ID token if the user consents. The ID token contains identity claims such as 'sub' and 'name', effectively bypassing the intended scope restriction. This issue affects versions from 2.12.3 up to but not including 4.1.1 and is fixed in version 4.1.1.
References
- github.com/authlib/authlib/security/advisories/GHSA-q686-2qmg-hqc7 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-114619 (opens in a new tab)
- github.com/authlib/authlib/pull/945 (opens in a new tab)
- github.com/authlib/authlib/commit/e3bd41cb29dcfee434453b135ffb487884baeedf (opens in a new tab)
- github.com/authlib/authlib (opens in a new tab)
- github.com/authlib/authlib/releases/tag/v1.9.0 (opens in a new tab)