CVE-2026-28802: Setting `alg · none` and a blank signature appears to bypass signature verification
Affects fastmcpSource GCVE Database
Public exploit available · CVSS 8.7 High : upgrade to 3.0.0 as a priority.
Data as of 3 Nov 2026, 22:58 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 45% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.0.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.
What to do
Upgrade fastmcp to 3.0.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewfastmcppkg:brew/fastmcpOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Authlib version 3.0.0 that fixes this vulnerability by rejecting tokens with 'alg: none' by default. Users should upgrade to version 3.0.0 or later. Until upgrading, applications must implement explicit checks to disallow 'alg: none' tokens to prevent acceptance of forged JWTs. The vendor does not indicate any automatic mitigation or that no action is required.
Description
A vulnerability in the Authlib library versions >=2.12.4_1 and <3.0.0 allows JWT tokens with the header 'alg: none' and an empty signature to bypass signature verification. This issue was introduced in version 1.6.0 and persists through 1.6.5. Applications using affected versions may accept forged JWTs without proper verification, leading to authentication bypass and privilege escalation. The vulnerability is fixed in version 3.0.0.
References
- github.com/authlib/authlib/security/advisories/GHSA-7wc2-qxgw-g8gg (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-28802 (opens in a new tab)
- github.com/authlib/authlib/commit/a61c2acb807496e67f32051b5f1b1d5ccf8f0a75 (opens in a new tab)
- github.com/authlib/authlib/commit/b87c32ed07b8ae7f805873e1c9cafd1016761df7 (opens in a new tab)
- github.com/authlib/authlib (opens in a new tab)