Skip to main content
CVE-2026-121880VulnerabilityPublished

Posit Software, PBC · Insecure Direct Object Reference

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-121880· Medium 4.7

Public exploit available · CVSS 4.7 Medium : upgrade to 2026.08.0 as a priority.

Data as of 6 Nov 2026, 19:33 UTC

CVSS 4.0 base score
4.7Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (POSIT)CVSS 4.04.7
Patch
Available – fixed in 2026.08.0
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:P/AU:Y/R:A/V:D/RE:M/U:Amber

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade Posit Workbench and RStudio Server to 2026.08.0.

Affected software

ProductAffectedFixed in
Posit Software, PBCPosit WorkbenchAffected
  • <2026.08.0
Fixed in
  • 2026.08.0
Posit Software, PBCRStudio ServerAffected
  • <2026.08.0
Fixed in
  • 2026.08.0

AI-suggested

A fix is available in Posit Software, PBC RStudio Server and Posit Workbench version 2026.08.0 and later. Users should upgrade to this version or later to remediate the vulnerability. No other configuration settings or temporary mitigations fully prevent this bypass without disabling all application proxying. Since this is not a cloud service, remediation depends on applying the official vendor update.

Description

A vulnerability in Posit Software, PBC RStudio Server and Posit Workbench before version 2026.08.0 allows remote authenticated users to bypass authorization controls in the localhost port-proxy feature. This flaw enables an attacker to access web applications and services bound to 127.0.0.1 under another user's session by using a proxy URL constructed from their own port token. Exploitation requires an authenticated account on the same multi-user server and a target service listening on localhost. The vulnerability is due to the port token being an obfuscation measure rather than an authorization boundary, and the proxy does not verify port ownership by the requesting user.

References

Community reviews

Loading reviews…