In JetBrains Datalore before 2026.4 improper scope validation in database tasks allowed using another workspace's
Source GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 2026.4 soon.
Data as of 6 Nov 2026, 19:17 UTC
Thin evidence
One scorer or none| CNA (JetBrains) | CVSS 3.1 | 7.5 |
|---|
- Patch
- Available – fixed in 2026.4
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 6 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade Datalore to 2026.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| JetBrainsDatalore | Affected
| Fixed in
|
AI-suggested
A fix is available in JetBrains Datalore version 2026.4. Users should upgrade to version 2026.4 or later to remediate this vulnerability. No additional mitigation guidance is provided.
Description
JetBrains Datalore versions before 2026.4 contain a vulnerability involving improper scope validation in database tasks. This flaw allows an attacker to use another workspace's service account, potentially leading to unauthorized access. The vulnerability has a high severity rating with a CVSS score of 7.5.