Skip to main content
VulnerabilityPublished Updated

Aurora PostgreSQL Instance · AWS Advanced Go Wrapper: Privilege Escalation

Affects github.com/aws/aws-advanced-go-wrapper/awssqlSource GCVE Database

0

CVSS 8.0 High : upgrade to 1.1.1 soon.

Data as of 27 Oct 2026, 00:07 UTC

CVSS 3.1 base score
8.0High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.1.1, 1.0.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

What to do

Upgrade github.com/aws/aws-advanced-go-wrapper/awssql to 1.1.1; github.com/aws/aws-advanced-go-wrapper/auth-helpers and github.com/aws/aws-advanced-go-wrapper/aws-secrets-manager and github.com/aws/aws-advanced-go-wrapper/federated-auth and github.com/aws/aws-advanced-go-wrapper/iam and github.com/aws/aws-advanced-go-wrapper/mysql-driver and github.com/aws/aws-advanced-go-wrapper/okta and github.com/aws/aws-advanced-go-wrapper/otlp and github.com/aws/aws-advanced-go-wrapper/pgx-driver and github.com/aws/aws-advanced-go-wrapper/xray to 1.0.2.

Affected software

ProductAffectedFixed in
Gogithub.com/aws/aws-advanced-go-wrapper/awssqlAffected
  • <1.1.1
Fixed in
  • 1.1.1
Gogithub.com/aws/aws-advanced-go-wrapper/auth-helpersAffected
  • <1.0.2
Fixed in
  • 1.0.2
Gogithub.com/aws/aws-advanced-go-wrapper/aws-secrets-managerAffected
  • <1.0.2
Fixed in
  • 1.0.2
Gogithub.com/aws/aws-advanced-go-wrapper/federated-authAffected
  • <1.0.2
Fixed in
  • 1.0.2
Gogithub.com/aws/aws-advanced-go-wrapper/iamAffected
  • <1.0.2
Fixed in
  • 1.0.2
Gogithub.com/aws/aws-advanced-go-wrapper/mysql-driverAffected
  • <1.0.2
Fixed in
  • 1.0.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

### Description of Vulnerability: An issue in AWS Wrappers for Amazon Aurora PostgreSQL may allow for privilege escalation to rds_superuser role. A low privilege authenticated user can create a crafted function that could be executed with permissions of other Amazon Relational Database Service (RDS) users. We recommend customers upgrade to the following versions: AWS Go Wrapper to 2025-10-17 ### Source of Vulnerability Report: Allistair Ishmael Hakim [allistair.hakim@gmail.com](mailto:allistair.hakim@gmail.com) ### Affected products & versions: AWS Go Wrapper < 2025-10-17 ### Platforms: MacOS/Windows/Linux

References

Community reviews

Loading reviews…