Bagisto before 2.4.4 contains a stored cross-site scripting vulnerability via client-side template injection that
Affects bagistoSource GCVE Database
Not known to be exploited · CVSS 5.4 Medium : upgrade to 2.4.4 when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Affects
- Webkul Bagisto before 2.4.4
- Patch
- Available – fixed in 2.4.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:N/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 9 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade bagisto/bagisto to 2.4.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubbagisto/bagistopkg:github/bagisto/bagistoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Webkul Bagisto version 2.4.4 and later. Users should upgrade to version 2.4.4 or newer to remediate this vulnerability. Since this is not a cloud service, remediation depends on applying the official patch. No vendor advisory content was provided to indicate alternative mitigations or temporary fixes. Patch status is not explicitly confirmed in vendor advisories here, so verify with Webkul's official resources for the latest remediation guidance.
Description
CVE-2026-60120 is a stored cross-site scripting (XSS) vulnerability in Webkul Bagisto versions before 2.4.4. It arises from improper neutralization of input during web page generation, specifically via client-side template injection. An unauthenticated attacker can exploit this by registering a customer account with malicious JavaScript payloads in the first or last name fields. The vulnerability occurs because the create.blade.php template renders these fields without the Vue.js v-pre directive, causing Vue.js to execute stored template expressions as live JavaScript when an administrator views the Create Order page for that customer. This can lead to arbitrary JavaScript execution in administrator browsers.