Skip to main content
CVE-2025-9222VulnerabilityPublished Updated

CVE-2025-9222: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab

Affects gitlabSource GCVE Database

0

Not known to be exploited · fixed in 18.7.1 : patch gitlab soon.

Data as of 25 Oct 2026, 19:02 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 18.7.1, 18.6.3, 18.5.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade gitlab to 18.7.1, 18.6.3 or 18.5.5.

Affected software

ProductAffectedFixed in
Bitnamigitlabpkg:bitnami/gitlabOther threatsAffected
  • >=18.2.2 <18.5.5
  • >=18.6.0 <18.6.3
  • >=18.7.0 <18.7.1
Fixed in
  • 18.5.5
  • 18.6.3
  • 18.7.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to affected GitLab CE/EE versions. Specifically, upgrade to GitLab versions 18.5.5 or later, 18.6.3 or later, or 18.7.1 or later. No additional mitigations are indicated by the vendor advisory. Red Hat notes that OpenShift Container Platform and OpenShift Pipelines are not affected as they do not include the vulnerable code.

Description

A stored cross-site scripting (XSS) vulnerability exists in GitLab CE/EE versions from 18.2.2 before 18.5.5, 18.6 before 18.6.3, and 18.7 before 18.7.1. An authenticated user could exploit GitLab Flavored Markdown to inject malicious scripts that execute in other users' browsers. This vulnerability has been remediated by GitLab.

References

Community reviews

Loading reviews…