Skip to main content
CVE-2026-119718VulnerabilityPublished

Blender before 4.5.15 and 5.x before 5.2.3 contains a heap buffer overflow vulnerability caused by integer overflow in

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-119718· High 8.5

Not known to be exploited · CVSS 8.5 High : upgrade to 5.2.3 or 4.5.15 soon.

Data as of 30 Oct 2026, 20:19 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.5
CNA (VulnCheck)CVSS 3.17.8
CNACVSS 4.08.5
Patch
Available – fixed in 5.2.3, 4.5.15
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade Blender to 5.2.3 or 4.5.15.

Affected software

ProductAffectedFixed in
Blender FoundationBlenderAffected
  • >=5.0.0 <5.2.3
Fixed in
  • 5.2.3
Blender FoundationBlenderAffected
  • <4.5.15
Fixed in
  • 4.5.15

AI-suggested

Users should upgrade Blender to version 4.5.15 or later, or 5.2.3 or later, where this vulnerability is fixed. Since the vulnerability is patched in these versions, applying the official update is the recommended remediation. No additional mitigations are specified.

Description

Blender versions before 4.5.15 and 5.x before 5.2.3 contain a heap buffer overflow vulnerability caused by an integer overflow in the ptcache_data_alloc() function when reading point cache files. An attacker can supply a crafted point cache file with a large totpoint value alongside a .blend file to cause a crash or execute arbitrary code with the user's privileges.

References

Community reviews

Loading reviews…