Blender before 4.5.15 and 5.x before 5.2.3 contains a heap buffer overflow vulnerability in the blend file thumbnail
Source GCVE Database
Not known to be exploited · CVSS 8.5 High : upgrade to 5.2.3 or 4.5.15 soon.
Data as of 30 Oct 2026, 20:19 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.5 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.8 |
| CNA | CVSS 4.0 | 8.5 |
- Patch
- Available – fixed in 5.2.3, 4.5.15
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Blender to 5.2.3 or 4.5.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Blender FoundationBlender | Affected
| Fixed in
|
| Blender FoundationBlender | Affected
| Fixed in
|
AI-suggested
Users should upgrade Blender to version 4.5.15 or later, or 5.2.3 or later, where this vulnerability is fixed. No other mitigation or workaround is indicated. Patch status is confirmed by the version boundaries given in the description.
Description
A heap buffer overflow vulnerability exists in Blender versions before 4.5.15 and 5.x before 5.2.3. The flaw is caused by a 32-bit integer overflow in the thumb_data_vertical_flip() function used by the blend file thumbnail extractor. Maliciously crafted .blend files with specially designed TEST block dimensions can trigger out-of-bounds writes when previewed by blender-thumbnailer or the Windows shell extension, potentially leading to crashes or arbitrary code execution.
References
- nvd.nist.gov/vuln/detail/CVE-2026-119719 (opens in a new tab)
- projects.blender.org/blender/blender (opens in a new tab)
- projects.blender.org/blender/blender/commit/71c10a0217d5e331b215b76773ad23b64974bd97 (opens in a new tab)
- projects.blender.org/blender/blender/commit/d723c68112d216099c9b24dab5c8440bab7add08 (opens in a new tab)
- projects.blender.org/blender/blender/pulls/164279 (opens in a new tab)
- vulncheck.com/advisories/blender-before-4.5.15-and-5-x-before-5.2.3-heap-buffer-overflow-via-thumbnail-extraction (opens in a new tab)