CVE-2026-93577: GitLab · Integer Overflow or Wraparound
Affects GitLabSource CVE Database V5
Not known to be exploited · CVSS 9.9 Critical · fixed in 19.4.1 : patch GitLab as a priority.
Data as of 30 Oct 2026, 23:51 UTC
Thin evidence
One scorer or none| CNA (GitLab) | CVSS 3.1 | 9.9 |
|---|
- CISA SSVC
- Exploitation
- No evidence of active exploitation and no public proof of concept
- Automatable
- Attackers cannot reliably automate steps 1–4 of the kill chain
- Technical impact
- Total control over the software or total information disclosure
CISA SSVC assessment, 2026-09-24.
- Patch
- Available – fixed in 19.4.1, 19.3.3, 19.2.7
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 23 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade GitLab and gitlab to 19.4.1, 19.3.3 or 19.2.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| GitLabGitLab | Affected
| Fixed in
|
| GitLabGitLab | Affected
| Fixed in
|
| GitLabGitLab | Affected
| Fixed in
|
RubyGemsgitlabpkg:gem/gitlabOther threats | Affected
| Fixed in
|
CPE configurations (1)
cpe:2.3:a:gitlab:gitlab:*:*:*:*:*:*:*:*
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade affected GitLab CE/EE instances to versions 19.2.7, 19.3.3, or 19.4.1 or later, where the integer overflow vulnerability has been fixed. No other mitigation or workaround is indicated.
Description
CVE-2026-93577 is a critical integer overflow vulnerability in GitLab CE/EE versions 19.2 prior to 19.2.7, 19.3 prior to 19.3.3, and 19.4 prior to 19.4.1. It allows an authenticated user to execute arbitrary code on the GitLab server by exploiting an integer overflow when compiling a specially crafted regular expression in a CI/CD configuration.