Blender before 4.5.15 and 5.x before 5.2.3 contains an out-of-bounds read vulnerability in blo_bhead_id_ accessors in
Source GCVE Database
Not known to be exploited · CVSS 6.9 Medium : upgrade to 5.2.3 or 4.5.15 when convenient.
Data as of 30 Oct 2026, 20:03 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 6.9 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 6.1 |
| CNA | CVSS 4.0 | 6.9 |
- Patch
- Available – fixed in 5.2.3, 4.5.15
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:L/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade Blender to 5.2.3 or 4.5.15.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Blender FoundationBlender | Affected
| Fixed in
|
| Blender FoundationBlender | Affected
| Fixed in
|
AI-suggested
Users should upgrade Blender to version 4.5.15 or later, or 5.2.3 or later, where this vulnerability is fixed. Since fixed versions are explicitly stated, applying these official patches will remediate the issue.
Description
Blender versions before 4.5.15 and 5.x before 5.2.3 contain an out-of-bounds read vulnerability in the blo_bhead_id_* accessors within readfile.cc. This flaw allows crafted .blend files with short ID blocks to cause heap over-reads, potentially leading to application crashes or disclosure of heap memory.
References
- nvd.nist.gov/vuln/detail/CVE-2026-119721 (opens in a new tab)
- projects.blender.org/blender/blender (opens in a new tab)
- projects.blender.org/blender/blender/commit/495deb9efff880c42aa88110aec0ea2c0fb1eb07 (opens in a new tab)
- projects.blender.org/blender/blender/commit/7de4986e74ed47f67e78eb4b76609bb6d1ae8a0e (opens in a new tab)
- projects.blender.org/blender/blender/commit/94d99b362b0d236dcf07a96c1c8f9f5389d0583c (opens in a new tab)
- projects.blender.org/blender/blender/commit/c5d6faf04bf3f17efb6c404896ef0e7427784da5 (opens in a new tab)
- projects.blender.org/blender/blender/pulls/164279 (opens in a new tab)
- vulncheck.com/advisories/blender-before-4.5.15-and-5-x-before-5.2.3-out-of-bounds-read-via-blo-bhead-id-accessors (opens in a new tab)