Skip to main content
VulnerabilityPublished

CVE-2026-77053: boneIO Black firmware ships with authentication disabled by default

Source GCVE Database

0
Authoritative record:CVE-2026-77053· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 1.6.0 soon.

Data as of 26 Oct 2026, 16:30 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.6.0
CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:L/SI:L/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade boneIO and boneio to 1.6.0.

Affected software

ProductAffectedFixed in
boneIOboneioAffected
  • >=1.0.0 <1.6.0
Fixed in
  • 1.6.0
GitHubboneiopkg:github/boneioOther threatsAffected
  • >=1.0.0 <1.6.0
Fixed in
  • 1.6.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected devices to firmware version 1.6.0 or later, which enforces administrator account creation and restricts API access to authenticated users. Devices running versions prior to 1.2.0 cannot be upgraded in place and must be re-flashed with the 1.6.0 system image. No other mitigations are indicated.

Description

The boneIO Black firmware has a critical security vulnerability where authentication is disabled by default. The management web API listens on all network interfaces and exposes all endpoints without requiring credentials, allowing unauthenticated remote attackers full control over the device. This can lead to denial of service, configuration changes, and manipulation of connected physical circuits. The issue is fixed in version 1.6.0, which enforces administrator account creation and restricts API access to authenticated roles. Versions before 1.2.0 are unsupported and require re-flashing with the fixed system image.

References

Community reviews

Loading reviews…