Skip to main content
CVE-2026-26740VulnerabilityPublished Updated

giflib v.5.2.2 · Buffer Overflow Vulnerability

Affects giflibSource GCVE Database

0
Compare
Authoritative record:CVE-2026-26740· High 8.2

Not known to be exploited · CVSS 8.2 High · fixed in 5.1.9-2ubuntu0.3 : patch giflib soon.

Data as of 29 Oct 2026, 18:38 UTC

CVSS 3.1 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 5.1.9-2ubuntu0.3, 5.2.2-1ubuntu1.2, 5.2.2-1ubuntu3.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Ubuntu giflib to 5.1.9-2ubuntu0.3 (package) or 5.2.2-1ubuntu1.2 (package) or 5.2.2-1ubuntu3.2 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSgiflibpkg:deb/ubuntu/giflib?arch=source&distro=resoluteOther threatsAffected
  • <5.2.2-1ubuntu3.2
Fixed in
  • 5.2.2-1ubuntu3.2
Ubuntu 25.10giflibpkg:deb/ubuntu/giflib?arch=source&distro=questingOther threatsAffected
  • =5.2.2-1ubuntu2
Fixed in–
Ubuntu 24.04 LTSgiflibpkg:deb/ubuntu/giflib?arch=source&distro=nobleOther threatsAffected
  • <5.2.2-1ubuntu1.2
Fixed in
  • 5.2.2-1ubuntu1.2
Ubuntu 22.04 LTSgiflibpkg:deb/ubuntu/giflib?arch=source&distro=jammyOther threatsAffected
  • <5.1.9-2ubuntu0.3
Fixed in
  • 5.1.9-2ubuntu0.3
Ubuntu 20.04 LTSgiflibpkg:deb/ubuntu/giflib?arch=source&distro=focalOther threatsAffected
  • =5.1.4-3ubuntu1
  • =5.1.9-1
  • =5.1.9-1ubuntu0.1
Fixed in–
Ubuntu Pro 18.04 LTSgiflibpkg:deb/ubuntu/giflib?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 5.1.4-1 – 5.1.4-2ubuntu0.1+esm1
4 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Buffer Overflow vulnerability in giflib v.5.2.2 allows a remote attacker to cause a denial of service via the EGifGCBToExtension overwriting an existing Graphic Control Extension block without validating its allocated size.

References

Community reviews

Loading reviews…