CVE-2026-27614: Bugsink is vulnerable to Stored XSS via Pygments fallback in stacktrace rendering
Affects bugsinkSource GCVE Database
Not known to be exploited · CVSS 9.3 Critical : upgrade to 2.0.13 as a priority.
Data as of 27 Oct 2026, 17:57 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.0.13
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 25 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade bugsink to 2.0.13.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIbugsink | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied by upgrading Bugsink to version 2.0.13 or later. This update fixes the stored XSS vulnerability by properly handling the Pygments fallback scenario and sanitizing input before rendering. Until patched, administrators should be cautious when viewing stacktraces from untrusted sources. No other mitigations are specified by the vendor advisory.
Description
Bugsink versions prior to 2.0.13 are vulnerable to a stored Cross-Site Scripting (XSS) flaw via the Pygments fallback mechanism in stacktrace rendering. An unauthenticated attacker who can submit events to a Bugsink project can inject arbitrary JavaScript payloads into event data. The malicious script executes only when an administrator views the affected stacktrace in the Bugsink web UI. The vulnerability arises because when Pygments returns more lines than requested, Bugsink falls back to rendering raw input lines without proper sanitization, applying mark_safe unconditionally. This allows stored XSS payloads to persist in the database and execute in the context of an admin user.
References
- github.com/bugsink/bugsink/security/advisories/GHSA-vp6q-7m36-pq3w (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-27614 (opens in a new tab)
- github.com/bugsink/bugsink/commit/e784d6aeb0d5f29b40c2779d2544c2b9ef097ee9 (opens in a new tab)
- github.com/bugsink/bugsink (opens in a new tab)
- github.com/bugsink/bugsink/releases/tag/2.0.13 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/bugsink/PYSEC-2026-301.yaml (opens in a new tab)
- pypi.org/project/bugsink (opens in a new tab)