Skip to main content
VulnerabilityPublished

scope missing slot-id validation · Cedar: JSON template is

Affects cedar-policySource GCVE Database

0

CVSS 2.1 Low : upgrade to 4.11.1 when convenient.

Data as of 29 Oct 2026, 17:22 UTC

CVSS 4.0 base score
2.1Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.11.1, 3.4.3
CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:L/SC:L/SI:L/SA:L

What to do

Upgrade cedar-policy and @cedar-policy/cedar-wasm to 4.11.1; cedar-policy and @cedar-policy/cedar-wasm to 3.4.3.

Affected software

ProductAffectedFixed in
crates.iocedar-policyAffected
  • >=4.0.0 <4.11.1
Fixed in
  • 4.11.1
crates.iocedar-policyAffected
  • >=3.0.0 <3.4.3
Fixed in
  • 3.4.3
npm@cedar-policy/cedar-wasmAffected
  • >=4.0.1 <4.11.1
Fixed in
  • 4.11.1
npm@cedar-policy/cedar-wasmAffected
  • >=3.2.0 <3.4.3
Fixed in
  • 3.4.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Update Cedar to versions 4.11.1 or 3.4.3 where this issue is fixed. If updating is not possible, audit JSON format policy templates for malformed slot identifiers in 'is in' scope conditions, specifically checking for 'principal' using '?resource' and 'resource' using '?principal' slots, and correct them to conform to Cedar syntax. Avoid using malformed JSON policies to prevent linking errors and decision divergence.

Description

A vulnerability in Cedar JSON policy templates using the 'is in' scope condition allows malformed slot identifiers to cause linking errors or semantic mismatches. This can lead to policy panics or unintended authorization decisions, such as allowing access that should be forbidden. The issue affects only malformed JSON policies with incorrect slot identifiers in principal and resource constraints. Versions prior to 4.11.1 and 3.4.3 are affected. Patches are available in these fixed versions.

References

Community reviews

Loading reviews…