Skip to main content
VulnerabilityPublished Updated

CVE-2025-27219: CGI has Denial of Service (DoS) potential in Cookie.parse

Affects cgiSource GCVE Database

0
Compare
Authoritative record:CVE-2025-27219· Medium 5.8

Not known to be exploited · CVSS 5.8 Medium : upgrade to 0.3.5.1 when convenient.

Data as of 30 Oct 2026, 16:05 UTC

CVSS 3.1 base score
5.8Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (mitre)CVSS 3.15.8
Patch
Available – fixed in 0.3.5.1, 0.3.7, 0.4.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Mar 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade cgi to 0.3.5.1; cgi to 0.3.7; cgi to 0.4.2.

Affected software

ProductAffectedFixed in
RubyGemscgiAffected
  • <0.3.5.1
Fixed in
  • 0.3.5.1
RubyGemscgiAffected
  • >=0.3.6 <0.3.7
  • =0.3.6
Fixed in
  • 0.3.7
RubyGemscgiAffected
  • >=0.4.0 <0.4.2
Fixed in
  • 0.4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade the cgi gem to version 0.3.5.1, 0.3.7, 0.4.2, or later to apply the official fix. No other mitigations are indicated or necessary once patched.

Description

A denial of service (DoS) vulnerability exists in the cgi gem's CGI::Cookie.parse method due to super-linear parsing time for certain cookie strings. Maliciously crafted cookie input can cause excessive processing time, leading to DoS. Versions up to 0.3.5, 0.3.6, 0.4.0, and 0.4.1 are affected. Fixed versions include 0.3.5.1, 0.3.7, and 0.4.2 or later.

References

Community reviews

Loading reviews…