A denial of service (DoS) vulnerability exists in the cgi gem's CGI::Cookie.parse method due to super-linear parsing time for certain cookie strings. Maliciously crafted cookie input can cause excessive processing time, leading to DoS. Versions up to 0.3.5, 0.3.6, 0.4.0, and 0.4.1 are affected. Fixed versions include 0.3.5.1, 0.3.7, and 0.4.2 or later.