Skip to main content
CVE-2025-39663VulnerabilityPublished Updated

Checkmk: Schwachstelle ermöglicht Cross-Site Scripting

Affects Bundesamt für Sicherheit in der Informationstechnik CheckmkSource GCVE Database

0
Compare
Authoritative record:CVE-2025-39663· High 8.5

Not known to be exploited · CVSS 8.5 High · fixed in 2.4.0 : patch Bundesamt für Sicherheit in der Informationstechnik Checkmk soon.

Data as of 29 Oct 2026, 23:20 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
GitHubcheckmk/checkmkpkg:github/checkmk/checkmkOther threatsAffected
  • =2.2.0
  • =2.1.0
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Checkmk to version 2.4.0p14 or later, where this cross-site scripting vulnerability has been fixed.

Description

A cross-site scripting (XSS) vulnerability has been identified in Checkmk, an IT monitoring software. The issue affects versions prior to 2.4.0p14 and the exact version 2.4.0p14. A fix is available in version 2.4.0p14.

References

Community reviews

Loading reviews…